【澳门金沙vip】MDAC2.8 安装问题与解决方法

1、MDAC2.8安装问 题 在windows xp + sp2 环境下安装过程中出现提示:“mdac
2.8 Rtm 与此版本 windows 不兼容”。

 

XP   自带的MDAC   2.8   是无法重装滴  
唯一的办法就是替换源文件看看也许能行    
   
 
在“我的电脑”中找到Windows系统目录下INF文件夹中的MDAC.INF文件,在其上点击右键,在弹出的菜单中选择“安装”,当提示定位文件时,您可以先将其指向windows\servicepackfiles\i386,当需要XP的CD时,指向XP的安装盘上的\i386文件夹即可。(如果您的XP安装包中包括了SP2,您可以直接指向XP的安装盘上的i386文件夹就可以了。如果您的SP2是从网上升级的,可能需要先指向C:\windows\servicepackfiles\澳门金沙vip,i386文件夹,此处假定您的XP安装在C:\windows文件夹下)。  
   
  ————————  
  关掉其它程序进程,下载oledb32.zip按顺序解压缩到以下两个目录:  
  1)   C:\WINNT\system32\dllCache  
  2)   C:\Program   Files\Common   Files\System\OLE   DB  
  3)   dos下进入上面目录,regsvr32   oledb32.dll  
  (一定要按顺序,如果直接覆盖到C:\Program   Files\Common  
Files\System\OLE   DB目录不会成功)  
  下载oledb32.zip地址:  
   
  说明:  
 
安装MDAC2.8最新版本后仍没有解决问题,或者下载不了以上的oledb32.zip文件,请参照:  
 
即时下载最新MDAC2.8版本安装重启后发现仍没有解决问题(2003如是),因为oledb32.dll在安装仍没有被覆盖。可以这样解决:解压缩下载的MDAC_TYP.exe,找到一个mdacxpak.cab文件,再解压缩,就有了我们要的oledb32.dll文件,按上面步骤覆盖掉两个目录下的文件,再注册组件就可。  

解决办 法:现在MDAC2.8的所有功能都成为
windowsXPSP2的一部分,该提示正常,不会影响使用。
你的系统是WINXP-SP2,系统自带MDAC 2.8 SP2,因此你不能安装MDAC 2.8,而且
WINXP-SP2不能卸载MDAC,他是系统的核心部件,只能通过安装SERVICE PACK
的后续版本升级你的MDAC,并且不能往回滚动到以前版本的MDAC. 如果你
安装下载了MDAC 微软数据访问组件版本2.8,安装到WINXP
SP2的机器,你将收到如下错误信息 这个版 本mdac 2.8 Rtm
和你的WINDOWS不兼容 你的系统版本和你准备安装的软件版本不兼容 Method

Prash Shirolkar, Author
Alyssa Henry, Contributor
Stephen Pepitone, Contributor
Acey J. Bunch, Contributor
Microsoft Corporation

摘要:了解 Microsoft 数据访问技术的过去、现在和未来。

澳门金沙vip 1

1: Install MDAC 2.81 方法1 安装MDAC 2.81

()
关于如何安装MDAC2.81的信息,请访问。这个MDAC2.8 SP1分发安装包和 WINXP
SP2附带安装的是同一数据访问组件。 Method
2: Repair the MDAC 2.81 installation that is included with Windows XP
SP2 方法2 修补WINXP SP2自带的MDAC 2.81安装
如果你不能看得WINDOWS的INF目录,进行如下步骤, 点击 开始 我的电脑
工具菜单 文件夹 选项 b. 点击 查看 c. 在高级设置下,点击
显示隐藏文件和文件夹 d. 去掉隐藏已知文 件的扩展名选项 e. 点击应用
点击确认

本页内容

澳门金沙vip 2
简介

澳门金沙vip 3
Microsoft 数据访问组件
(MDAC)

澳门金沙vip 4
SQL Native Client
(SQLNCLI)

澳门金沙vip 5
ADO.NET

澳门金沙vip 6
已过时的数据访问技术

澳门金沙vip 7
更多信息